LEVEL –1 TRAINING

MS EXCEL MAIN ELEMENTS ARE AS FOLLOWS:
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Go To Start ButtonProgramsMicrosoft Excel click

Here you can observe the Menu Bar, Standard tool bar and others, which is
shown above.
File Menu

Edit Menu
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Menu bar:
Menu bar contains the different menus. They are File menu, Edit menu, View
Menu, Insert Menu, Format Menu, Tools Menu, Table Menu, Window Menu, and
Help Menu.
File Menu:
In this menu you can start a new excel sheet, you can open existing sheet. You
can save this as a new sheet with a new name. You can save the excel sheet as
web page. In this menu you can set the page as your requirements from page
setup.
Edit Menu:
In this menu you can undo the previous commands. You can cut, copy and paste
the contents. You can fill the cells, clear the cells and you can delete the sheet
also. And you can find and replace the cell contents
View Menu:
In this menu you can view the sheet in two different views. They are Normal
View, Page break view. You can choose the different tools from tools tab. You
can choose the Header and Footer in this menu.
Insert Menu:
With this menu you can insert the cells, rows, columns, sheets charts, pictures
and hyperlinks. You can cal the functions also.
Format Menu:
In this menu you can format the Sheet, Row, Column and cell as your
requirement.
Tools Menu:
In this menu you can correct the spelling and grammar, you can share the
workbook, you can protect the workbook with password, you can change the
page options and you can run the macros also.
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Data Menu:
In this menu you can sort the data, filter the data, you can validate the cells, you
can create the pivot table and change the data to Ms Access.
Window:
In this menu you can hide the sheet, freeze the panes and you can create the
new sheet.
Help:
You can get the help topics about the Microsoft Excel.
Insert blank cells
1. Select a range of existing cells where you want to insert the new blank
cells. Select the same number of cells, as you want to insert.
2. On the Insert menu, click Cells.
3. Click Shift cells right or Shift cells down.
Insert rows
1. To insert a single row, click a cell in the row immediately below where you
want the new row. For example, to insert a new row above Row 5, click a
cell in Row 5.
To insert multiple rows, select rows immediately below where you want
the new rows. Select the same number of rows, as you want to insert.
2. On the Insert menu, click Rows.
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Insert columns
1. To insert a single column, click a cell in the column immediately to the
right of where you want to insert the new column. For example, to insert a
new column to the left of Column B, click a cell in Column B.
To insert multiple columns, select columns immediately to the right of
where you want to insert the new columns. Select the same number of
columns, as you want to insert.
2. On the Insert menu, click Columns.
Insert moved or copied cells between existing cells
1. Select the cells that contain the data you want to move or copy.
2. To move the selection, click Cut
To copy the selection, click Copy

.
.

3. Select the upper-left cell where you want to place the cut or copied cells.
4. On the Insert menu, click Cut Cells or Copied Cells.
5. Click the direction you want to shift the surrounding cells.
Insert a new worksheet


To add a single worksheet, click Worksheet on the Insert menu.
To add multiple worksheets, hold down SHIFT, and then click the number
of worksheet tabs you want to add in the open workbook. Then click
Worksheet on the
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Move or copy sheets
Caution Be careful when you move or copy sheets. Calculations or charts
based on data on a worksheet might become inaccurate if you move the
worksheet. Similarly, if you move a worksheet between sheets referred to by a 3D formula reference, data on the worksheet might be included in the calculation.
1. To move or copy sheets to another existing workbook, open the workbook
that will receive the sheets.
2. Switch to the workbook that contains the sheets you want to move or
copy, and then select the sheets.
3. On the Edit menu, click Move or Copy Sheet.
4. In the to book box, click the workbook to receive the sheets.
To move or copy the selected sheets to a new workbook, click new book.
5. In the before sheet box, click the sheet before which you want to insert the
moved or copied sheets.
6. To copy the sheets instead of move them, select the Create a copy check
box.

Keys for entering data
Note To enlarge the Help window to fill the screen, press ALT+SPACEBAR and
then press X. To restore the window to its previous size and location, press
ALT+SPACEBAR and then press R. To print this topic, press ALT+O and then
press P.
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Keys for entering data on a worksheet
Press

To

ENTER

Complete a cell entry and move down in the
selection

ALT+ENTER

Start a new line in the same cell

CTRL+ENTER

Fill the selected cell range with the current entry

SHIFT+ENTER

Complete a cell entry and move up in the selection

TAB

Complete a cell entry and move to the right in the
selection

SHIFT+TAB

Complete a cell entry and move to the left in the
selection

ESC

Cancel a cell entry

BACKSPACE

Delete the character to the left of the insertion point,
or delete the selection

DELETE

Delete the character to the right of the insertion
point, or delete the selection

CTRL+DELETE

Delete text to the end of the line

Arrow keys

Move one character up, down, left, or right

HOME

Move to the beginning of the line

F4 or CTRL+Y

Repeat the last action

SHIFT+F2

Edit a cell comment

CTRL+SHIFT+F3

Create names from row and column labels

CTRL+D

Fill down

CTRL+R

Fill to the right

CTRL+F3

Define a name

Keys for working in cells or the formula bar
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Press

To

BACKSPACE

Edit the active cell and then clear it, or delete the
preceding character in the active cell as you edit cell
contents

ENTER

Complete a cell entry

CTRL+SHIFT+ENTER

Enter a formula as an array formula

ESC

Cancel an entry in the cell or formula bar

CTRL+A

Display the Formula Palette after you type a
function name in a formula

CTRL+SHIFT+A

Insert the argument names and parentheses for a
function after you type a function name in a formula

CTRL+K

Insert a hyperlink

ENTER (in a cell with a
hyperlink)

Activate a hyperlink

F2

Edit the active cell and position the insertion point at
the end of the line

F3

Paste a defined name into a formula

SHIFT+F3

Paste a function into a formula

F9

Calculate all sheets in all open workbooks

CTRL+ALT+F9

Calculate all sheets in the active workbook

SHIFT+F9

Calculate the active worksheet

= (Equal sign)

Start a formula

ALT+= (equal sign)

Insert the AutoSum formula

CTRL+; (semicolon)

Enter the date

CTRL+SHIFT+: (colon)

Enter the time

CTRL+SHIFT+" (quotation mark) Copy the value from the cell above the active cell
into the cell or the formula bar
CTRL+` (single left quotation
mark)

Alternate between displaying cell values and
displaying cell formulas

CTRL+' (apostrophe)

Copy a formula from the cell above the active cell
into the cell or the formula bar
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ALT+DOWN ARROW

Display the AutoComplete list

Keys for formatting data
Note To enlarge the Help window to fill the screen, press ALT+SPACEBAR and
then press X. To restore the window to its previous size and location, press
ALT+SPACEBAR and then press R. To print this topic, press ALT+O and then
press P.
Press

To

ALT+' (apostrophe)

Display the Style dialog box

CTRL+1

Display the Format Cells dialog box

CTRL+SHIFT+~

Apply the General number format

CTRL+SHIFT+$

Apply the Currency format with two decimal places
(negative numbers appear in parentheses)

CTRL+SHIFT+%

Apply the Percentage format with no decimal places

CTRL+SHIFT+^

Apply the Exponential number format with two
decimal places

CTRL+SHIFT+#

Apply the Date format with the day, month, and year

CTRL+SHIFT+@

Apply the Time format with the hour and minute, and
indicate A.M. or P.M.

CTRL+SHIFT+!

Apply the Number format with two decimal places,
thousands separator, and minus sign (–) for negative
values

CTRL+SHIFT+&

Apply the outline border

CTRL+SHIFT+_

Remove outline borders

CTRL+B

Apply or remove bold formatting

CTRL+I

Apply or remove italic formatting

CTRL+U

Apply or remove an underline

CTRL+5

Apply or remove strikethrough formatting

CTRL+9

Hide rows

CTRL+SHIFT+((opening
parenthesis)

Unhide rows

CTRL+0 (zero)

Hide columns
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CTRL+SHIFT+) (closing
parenthesis)

Unhide columns

Keys for editing data
Note To enlarge the Help window to fill the screen, press ALT+SPACEBAR and
then press X. To restore the window to its previous size and location, press
ALT+SPACEBAR and then press R. To print this topic, press ALT+O and then
press P.

Keys for editing data
Press

To

F2

Edit the active cell and put the insertion point at
the end of the line

ESC

Cancel an entry in the cell or formula bar

BACKSPACE

Edit the active cell and then clear it, or delete the
preceding character in the active cell as you edit
the cell contents

F3

Paste a defined name into a formula

ENTER

Complete a cell entry

CTRL+SHIFT+ENTER

Enter a formula as an array formula

CTRL+A

Display the Formula Palette after you type a
function name in a formula

CTRL+SHIFT+A

Insert the argument names and parentheses for a
function, after you type a function name in a
formula

F7

Display the Spelling dialog box

Keys for inserting, deleting, and copying a selection
Press
CTRL+C

To
Copy the selection
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CTRL+X

Cut the selection

CTRL+V

Paste the selection

DELETE

Clear the contents of the selection

CTRL+HYPHEN

Delete the selection

CTRL+Z

Undo the last action

CTRL+SHIFT+PLUS SIGN Insert blank cells

Keys for moving within a selection
Press

To

ENTER

Move from top to bottom within the selection (down),
or move in the direction that is selected on the Edit
tab (Tools menu, Options command)

SHIFT+ENTER

Move from bottom to top within the selection (up), or
move opposite to the direction that is selected on the
Edit tab (Tools menu, Options command)

TAB

Move from left to right within the selection, or move
down one cell if only one column is selected

SHIFT+TAB

Move from right to left within the selection, or move
up one cell if only one column is selected

CTRL+PERIOD

Move clockwise to the next corner of the selection

CTRL+ALT+RIGHT ARROW

Move to the right between nonadjacent selections

CTRL+ALT+LEFT ARROW

Move to the left between nonadjacent selections

Keys for selecting data and cells
Note To enlarge the Help window to fill the screen, press ALT+SPACEBAR and
then press X. To restore the window to its previous size and location, press
ALT+SPACEBAR and then press R. To print this topic, press ALT+O and then
press P.
This topic lists:

Keys for selecting cells, columns, or rows
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Press

To

CTRL+SHIFT+* (asterisk)

Select the current region around the active cell (the
current region is a data area enclosed by blank rows
and blank columns)

SHIFT arrow key

Extend the selection by one cell

CTRL+SHIFT+arrow key

Extend the selection to the last nonblank cell in the
same column or row as the active cell

SHIFT+HOME

Extend the selection to the beginning of the row

CTRL+SHIFT+HOME

Extend the selection to the beginning of the worksheet

CTRL+SHIFT+END

Extend the selection to the last used cell on the
worksheet (lower-right corner)

CTRL+SPACEBAR

Select the entire column

SHIFT+SPACEBAR

Select the entire row

CTRL+A

Select the entire worksheet

SHIFT+BACKSPACE

Select only the active cell when multiple cells are
selected

SHIFT+PAGE DOWN

Extend the selection down one screen

SHIFT+PAGE UP

Extend the selection up one screen

CTRL+SHIFT+SPACEBAR

With an object selected, select all objects on a sheet

CTRL+6

Alternate between hiding objects, displaying objects,
and displaying placeholders for objects

CTRL+7

Show or hide the Standard toolbar

F8

Turn on extending a selection by using the arrow keys

SHIFT+F8

Add another range of cells to the selection; or use the
arrow keys to move to the start of the range you want
to add, and then press F8 and the arrow keys to select
the next range

SCROLL LOCK,
SHIFT+HOME

Extend the selection to the cell in the upper-left corner
of the window

SCROLL LOCK, SHIFT+END

Extend the selection to the cell in the lower-right
corner of the window
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Tip When you use the scrolling keys (such as PAGE UP and PAGE DOWN)
with SCROLL LOCK turned off, your selection moves the distance you scroll. If
you want to keep the same selection as you scroll, turn on SCROLL LOCK first.

Keys for extending the selection with End mode on
Press

To

END

Turn End mode on or off

END, SHIFT+arrow key

Extend the selection to the last nonblank cell in the
same column or row as the active cell

END, SHIFT+HOME

Extend the selection to the last cell used on the
worksheet (lower-right corner)

END, SHIFT+ENTER

Extend the selection to the last cell in the current row.
This keystroke is unavailable if you selected the
Transition navigation keys check box on the
Transition tab (Tools menu, Options command).

Keys for selecting cells that have special
characteristics
Press

To

CTRL+SHIFT+* (asterisk)

Select the current region around the active cell (the
current region is a data area enclosed by blank rows
and blank columns)

CTRL+/

Select the current array, which is the array that the
active cell belongs to

CTRL+SHIFT+O (the letter O)

Select all cells with comments

CTRL+\

Select cells in a row that don't match the value in the
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active cell in that row. You must select the row
starting with the active cell.
CTRL+SHIFT+|

Select cells in a column that don't match the value in
the active cell in that column. You must select the
column starting with the active cell.

CTRL+[(opening bracket)

Select only cells that are directly referred to by
formulas in the selection

CTRL+SHIFT+{(opening brace) Select all cells that are directly or indirectly referred to
by formulas in the selection
CTRL+] (closing bracket)

Select only cells with formulas that refer directly to
the active cell

CTRL+SHIFT+} (closing brace) Select all cells with formulas that refer directly or
indirectly to the active cell
ALT+; (semicolon)

Select only visible cells in the current selection
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About using functions to calculate values
Functions are predefined formulas that perform calculations by using specific
values, called arguments, in a particular order, or structure. For example, the
SUM function adds values or ranges of cells, and the PMT function calculates the
loan payments based on an interest rate, the length of the loan, and the principal
amount of the loan.
Arguments Arguments can be numbers, text, logical values such as TRUE or
FALSE, arrays, error values such as #N/A, or cell references. The argument you
designate must produce a valid value for that argument. Arguments can also be
constants, formulas, or other functions. For more information about using a
function as an argument for another function, also known as nesting functions,
click

.

Structure The structure of a function begins with the function name, followed by
an opening parenthesis, the arguments for the function separated by commas,
and a closing parenthesis. If the function starts a formula, type an equal sign (=)
before the function name. As you create a formula that contains a function, the
Formula Palette will assist you. For more information about using the Formula
Palette, click

. For more information about how to enter a formula that

contains a function, click
.
About using the Formula Palette to enter and edit formulas
Entering formulas When you create a formula that contains a function, the
Formula Palette helps you enter worksheet functions. As you enter a function into
the formula, the Formula Palette displays the name of the function, each of its
arguments, a description of the function and each argument, the current result of
the function, and the current result of the entire formula. To display the Formula
Palette, click Edit Formula

in the formula bar.

In this example, the nested SUM function is being edited by using the Formula
Palette. The range K10:K19 is the only argument of the function and appears in
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the Number1 edit box. The value in each cell of the range appears to the right of
the edit box. The result of the SUM function (935) appears below the list of
arguments. The result of the entire formula is shown at the bottom; because the
sum of the range K10:K19 is not greater than or equal to 5,000, the result is 0.05,
or 5%.
Editing formulas You can use the Formula Palette to edit functions in formulas.
Select a cell that contains a formula, and then click Edit Formula

to display

the Formula Palette. The first function in the formula and each of its arguments
appear in the palette. You can edit the first function or edit another function in the
same formula by clicking in the formula bar anywhere within the function.

Calculation operators in formulas
Operators specify the type of calculation that you want to perform on the
elements of a formula. Microsoft Excel includes four different types of calculation
operators: arithmetic, comparison, text, and reference.
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Arithmetic operators To perform basic mathematical operations such as
addition, subtraction, or multiplication; combine numbers; and produce numeric
results, use the following arithmetic operators.
Arithmetic
operator

Meaning

Example

+ (Plus sign)

Addition

3+3

– (Minus sign)

Subtraction
Negation

3–1
–1

* (Asterisk)

Multiplication

3*3

/ (Forward slash) Division

3/3

% (Percent sign) Percent

20%

^ (Caret)

3^2 (the same as 3*3)

Exponentiation

Comparison operators You can compare two values with the following
operators. When using these operators compares two values, the result is a
logical value, either TRUE or FALSE.
Comparison
operator

Meaning

Example

= (Equal sign)

Equal to

A1=B1

> (Greater than sign)

Greater than

A1>B1

< (Less than sign)

Less than

A1<B1

>= (Greater than or
equal to sign)

Greater than or equal to

A1>=B1

<= (Less than or equal
to sign)

Less than or equal to

A1<=B1

<> (Not equal to sign)

Not equal to

A1<>B1

Text concatenation operator Use the ampersand (&) to join, or concatenate, one
or more text strings to produce a single piece of text.
Text
operator

Meaning

Example
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& (Ampersand)

Connects, or concatenates, two "North" & "wind" produce
values to produce one
"North wind"
continuous text value

Reference operators Combine ranges of cells for calculations with the following
operators.
Reference
operator

Meaning

: (Colon)

Range operator, which
produces one reference to all
the cells between two
references, including the two
references

, (Comma)

Union operator, which
combines multiple references
into one reference

Example
B5:B15

What does the error ##### mean?
A ##### error value occurs when the cell contains a number, date, or time that is
wider than the cell or when the cell contains a date and/or time formula that
produces a negative result.
Increase the width of the column You can resize the column by dragging the
boundary between the column headings.
Apply a different number format In some cases, you can change the cell's
number format to make the number fit within the existing cell width. For example,
decrease the number of decimal places after the decimal point. How to change
the way Microsoft Excel displays numbers, dates, and times.
Be sure date and time formulas are correct When you subtract dates and times,
make sure you build the formula correctly. If you are using the 1900 date system,
dates and times in Excel must be positive values. Therefore, subtracting a later
date or time from an earlier date or time would cause the error #####. (To use
the 1900 date system, click Options on the Tools menu, click the Calculation tab,
and clear the 1904 date system check box.) If the formula is correct, although the
result is a negative value, you can display the value by formatting the cell with a
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format that is not a date or time format. Click Cells on the Format menu, click the
Number tab, and then select a format that is not a date or time format.
About number formats
This topic provides reference information about:
The General number format
Built-in number formats
Custom number formats
In Microsoft Excel, you can use number formats to change the appearance of
numbers, including dates and times, without changing the number behind the
appearance. The number format you apply does not affect the actual cell
value — displayed in the formula bar — which Excel uses to perform
calculations.
The General number format
The General format is the default number format. For the most part, what you
enter in a cell that is formatted with the General format is what is displayed.
However, if the cell is not wide enough to show the entire number, the General
format rounds numbers with decimals and uses scientific notation for large
numbers. You can reset a number format to the General format.
Built-in number formats
Excel contains many built-in number formats you can choose from. To see a
complete list of these formats, click Cells on the Format menu, and then click the
Number tab. The formats appear in categories on the left, including accounting,
date, time, fraction, scientific, and text. The Special category includes formats for
postal codes and phone numbers. Options for each category appear to the right
of the Category list.
Custom number formats
If a built-in number format doesn't display data the way you want, you can use
the Custom category on the Number tab (Format menu, Cells command) to
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create a custom number format. Custom number formats use format codes that
describe how you want to display a number, date, time, or text.
Insert moved or copied cells between existing cells
1. Select the cells that contain the data you want to move or copy.
2. To move the selection, click Cut
To copy the selection, click Copy

.
.

3. Select the upper-left cell where you want to place the cut or copied cells.
4. On the Insert menu, click Cut Cells or Copied Cells.
5. Click the direction you want to shift the surrounding cells.
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